Heroku service degradation affecting Advanced Scheduler

Incident Report for Advanced Scheduler

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:25 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 20:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 20:41 UTC

Identified

Starting at 07:00 UTC, we have been experiencing a major service disruption.

The root cause has been identified as a major AWS outage that affects the Heroku Platform.

Systems have been recovering, but we continue to see latency issues and performance degradation.

More information is available here:

https://status.salesforce.com/incidents/20003365
https://status.heroku.com/incidents/2910
Posted Oct 20, 2025 - 18:19 UTC
This incident affected: Scheduler, Monitor, and Heroku.